Cisco Unity Connection Switch Version Failed

Posted by
Facebooktwitterredditpinterestlinkedintumblr

I recently upgraded Cisco Unity Connection cluster running version 10.0.1.10000-24 to the latest version 10.5.1.10000-7. Successfully upgraded the publisher to latest version but when I switched over I got an error stating Cisco Unity Connection switch version failed.

Cisco Unity Connection switch over failed

Downloaded the Cisco Unity Connection install logs off the server (from CUC CLI I ran this command – file get install *). Reviewed the install logs and saw the error.

09/09/2014 14:09:22 component_switch|(CAPTURE) + echo 'Inactive version of Subscriber Does not match with Publisher'\''s Inactive version'|<LVL::Debug>
09/09/2014 14:09:22 component_switch|(CAPTURE) Inactive version of Subscriber Does not match with Publisher's Inactive version|<LVL::Debug>
09/09/2014 14:09:22 component_switch|(CAPTURE) + exit 1|<LVL::Debug>
09/09/2014 14:09:22 component_switch|File:/opt/cisco/install/bin/component_switch:404, Function: execute_switch_commands(), /opt/cisco/connection/lib/install/uc_version_switch 10.0.1.10000-24 10.5.1.10000-7 /var/log/active/platform/log/cli.log failed (1)|<LVL::Error>
09/09/2014 14:09:22 appmanager.sh|Internal Error, File:/usr/local/bin/base_scripts/appmanager.sh:399, Function: switch_versions(), failed to switch components|<LVL::Critical>

The issue was the inactive version in Cisco Unity Connection subscriber didn’t match on publisher’s inactive version. After upgrading the subscriber to 10.5.1.10000-7, I successfully switched over the entire cluster to the latest version without any issues.

Leave a Reply

Your email address will not be published. Required fields are marked *

*