TranslatorX libgtk-x11-2.0.so.0 Cannot Open Shared Object File

Posted by
Facebooktwitterredditpinterestlinkedintumblr

Issue: TranslatorX doesn’t run on Ubuntu 14.04 LTS 64bit. Getting an error

[email protected]:/opt/TranslatorX10_0_0_2$ ./TranslatorX10_0_0_2
Failed to find/load Framework library
libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Solution: The problem is the architecture of my machine is 64-bit while the application is 32-bit.
The below command installs all the missing dependencies of various packages in order to get the 32-bit version of the application running.

sudo apt-get install libgtk2.0-0:i386

Leave a Reply

Your email address will not be published. Required fields are marked *

*